• slider image 58
:::
XOOPS Big5 語言檔翻譯

cbb3.08如何改為中文

discuss pic 2009-12-23 16:42:18
我的系統是centos5.x 加xoops2.3.3b 加CBB3.08
xoops是用utf-8, 顯示中文常。
CBB討論區雖然可輸入中文,但是所有界面的文字,圖形都是英文。
請問各位大大,要改那一個設定檔。
先謝謝囉 !
discuss pic 2009-12-24 14:28:32
參照:

polomi 寫道:
CBB討論區雖然可輸入中文,但是所有界面的文字,圖形都是英文。


文字 => 因為 /modules/newbb/language/ 之下沒有tchinese_utf8資料夾
圖形 => 這篇http://xoops.tn.edu.tw/modules/xforum/viewtopic.php?post_id=42675#forumpost42675 已有解答
主頁:睡蓮‧池水間(支援Android4.0+及iOS5+)|論壇:風起漣漪|作品區:軒榭亭臺
discuss pic 2009-12-25 00:04:41
參照:
waterlily
文字 => 因為 /modules/newbb/language/ 之下沒有tchinese_utf8資料夾
圖形 => 這篇http://xoops.tn.edu.tw/modules/xforum/viewtopic.php?post_id=42675#forumpost42675 已有解答

[/quote]
感謝waterlily的回覆,
再請教各位大大,在/modules/newbb/language/下,有一份tchinese檔案,是big5用的嗎? 是否需要轉檔。
圖形那一篇很精彩,我會找時間再仔細研究,因為我又重灌了cbb3.08,結果英文的設定部份都有,可是設定完後,回到前台只有主選單有CBB三個字,沒有討論區。如果點選CBB,則出現一份空白的網頁。
曾試著在空白網頁的網址後,加上index.php(因為查看有newbb/index.php這個檔案),結果仍是空白網頁。爬了一整天的文,可能方向不對,都無法成功。
如果大大們,有知道相關的文件,煩請告知。
還是先謝謝了。
discuss pic 2009-12-25 13:07:58
參照:

polomi 寫道:
感謝waterlily的回覆,
再請教各位大大,在/modules/newbb/language/下,有一份tchinese檔案,是big5用的嗎? 是否需要轉檔。




沒錯,是big 5用。
若要用utf8可以將tchinese資料夾更名為tchinese_utf8,還要將資料夾裡面的檔案轉碼。





參照:

polomi 寫道:
圖形那一篇很精彩,我會找時間再仔細研究,因為我又重灌了cbb3.08,結果英文的設定部份都有,可是設定完後,回到前台只有主選單有CBB三個字,沒有討論區。如果點選CBB,則出現一份空白的網頁。
曾試著在空白網頁的網址後,加上index.php(因為查看有newbb/index.php這個檔案),結果仍是空白網頁。爬了一整天的文,可能方向不對,都無法成功。
如果大大們,有知道相關的文件,煩請告知。
還是先謝謝了。



我猜可能在您重灌之前CBB卸載得不夠乾淨。
主頁:睡蓮‧池水間(支援Android4.0+及iOS5+)|論壇:風起漣漪|作品區:軒榭亭臺
discuss pic 2009-12-25 14:01:33
參照:
waterlily 寫道:
沒錯,是big 5用。
若要用utf8可以將tchinese資料夾更名為tchinese_utf8,還要將資料夾裡面的檔案轉碼。

我猜可能在您重灌之前CBB卸載得不夠乾淨。

感謝waterlily這麼快就回覆,我又有測試的方向。測試成功與否,再POST上來。
discuss pic 2009-12-28 22:14:28
我又重裝了二次的cbb3.08+Frameworks1.1+xoopseditor,
終於看到了可愛的繁體中文及有中文的ICON標籤,感謝waterlily指導。
我的作法是把上述模組,全部轉為tchinese_utf8,
包括所有內含的schinese_utf8, 更名為tchinese_utf8,
(因為我是用簡體的utf8,轉檔為繁體的utf8),

是否有些部份,不能改名(但內容確實已是繁體碼),造成
看不到FCKeditor編輯器,已啃了一天的英文,不過還不清楚狀況,
大大們,再請教正確的安裝程序。謝謝。
discuss pic 2009-12-29 21:33:52
您所說的繁體碼是指big5還是utf8?
編輯器 language 下的資料夾有沒有改名
仍是一樣會看到編輯器
有tchinese_utf8便會看到中文
沒有的話就顯示預設的英文

如果您的問題是看不到編輯器
那請到/xoops_data/caches/xoops_cache/xoops_editorlist.php 之下
先看看有沒有下面這一段吧

fckeditor' =>
array (
'title' => 'FCK 編輯器',
'nohtml' =>1,
),
主頁:睡蓮‧池水間(支援Android4.0+及iOS5+)|論壇:風起漣漪|作品區:軒榭亭臺
discuss pic 2009-12-30 00:32:50
[quote]
waterlily 寫道:
您所說的繁體碼是指big5還是utf8?====>>我用schinese_utf8轉為tchinese_utf8
編輯器 language 下的資料夾有沒有改名====>>有改,包括所有schinese.php都改為tchinese.php 這樣是否改太多了。

如果您的問題是看不到編輯器
那請到/xoops_data/caches/xoops_cache/xoops_editorlist.php 之下
先看看有沒有下面這一段吧

fckeditor' =>
array (
'title' => 'FCK 編輯器',
'nohtml' =>1,
),[/quote
是的,連xoops_editorlist.php都沒有,看了大大文章後,從別地方copy過來 ,再更新模組,可是依然無效,怕我的文字敘述不清楚,所以把圖試著貼出來,讓大大研究。
縮圖
縮圖縮圖
以上圈起來的連結都是空白,當然還是沒有編輯器。
第一次在此貼圖,有點手忙腳亂,不知道效果如何。
discuss pic 2009-12-30 00:39:59
[續上一頁]因為沒有編輯的權限,只好....................
補充一句:第一張圖沒有畫圈,是所有的可連結的文字,大部份上了連結都是空白。
discuss pic 2009-12-30 04:03:39
我一向不用預設編輯器以外的其他編輯器
這次我抽了一點時間再去認真摸索各編輯器下的檔案
並在XOOPS2.42測試站下做了測試
總算有一點了解

XOOPS 2.42 版之下只要單用CBB3.08模組就可以了
連Frameworks + xoopseditor 也不用

如果要指定各編輯器的排序
安裝之前可以先在/class/xoopseditor/編輯器名稱/editor_registry.php 檔案裡變更設定
修改 "order" 後面的數值
假設排在最先的就設1
其他編輯器分別依上下排序各設2,3,4....
0為不顯示編輯器
如果在安裝之後又想要變更/editor_registry.php 設定
改完後便要到/xoops_data/caches/xoops_cache/之下將xoops_editorlist.php刪除就可以了
新的xoops_editorlist.php會自動生成
編輯器排序也就更新

另外,在討論區設定之下
有個“允許使用HTML:”選項
在關閉狀態下
只可以看到DHTML和文本編輯器
如要看到其他的編輯器例如 FCK
便要將選項開啟才能看到






參照:

polomi 寫道:
您所說的繁體碼是指big5還是utf8?====>>我用schinese_utf8轉為tchinese_utf8
編輯器 language 下的資料夾有沒有改名====>>有改,包括所有schinese.php都改為tchinese.php 這樣是否改太多了。





編輯器 language 下只要有一個轉好後的tchinese_utf8資料夾,其他的不用理會也不需要去改,因為不會用到。







參照:

polomi 寫道:
以上圈起來的連結都是空白,當然還是沒有編輯器。




有畫圈圈是表示點按連結時進入的是空白頁面嗎?那這和編輯器又有什麼關係?是另外的問題吧?

可有查看過空白頁面的連結網址是否正確?CBB 3.08版有這樣的問題我還真沒見過耶~


另外您貼的三個叉燒包圖片為何會用http://xoops.tnc.edu.tw/var/xoops_data/caches/xoops_cache/****.jpg 這樣的奇怪路徑? @@









主頁:睡蓮‧池水間(支援Android4.0+及iOS5+)|論壇:風起漣漪|作品區:軒榭亭臺
discuss pic 2009-12-30 10:08:54
參照:

waterlily 寫道:

XOOPS 2.42 版之下只要單用CBB3.08模組就可以了
連Frameworks + xoopseditor 也不用===>請問您,那內建的編輯也叫xoopseditor嗎?

如果要指定各編輯器的排序
安裝之前可以先在/class/xoopseditor/編輯器名稱/editor_registry.php 檔案裡變更設定
修改 "order" 後面的數值.....................................編輯器排序也就更新
另外,在討論區設定之下
有個“允許使用HTML:”選項....................要將選項開啟才能看到
===>以上對我而言是很寶貴的資料

編輯器 language 下只要有一個轉好後的tchinese_utf8資料夾,其他的不用理會也不需要去改,因為不會用到。===>那我是畫蛇添足了



從大大的提示中,了解可能是畫蛇添足造成的, 因為也把許多php檔,也一併轉檔,更名。看來需再重新轉檔,重新安裝cbb3.08。

當初我下載cbb3.08時,附註要一併下載Frameworks + xoopseditor ,所以才會一起裝。


我的叉燒包貼圖路徑,是上傳後,直接按右鍵複製路徑,再貼上來。不好意思,動作不標準。
discuss pic 2009-12-30 14:47:42
參照:

polomi 寫道:

XOOPS 2.42 版之下只要單用CBB3.08模組就可以了
連Frameworks + xoopseditor 也不用===>請問您,那內建的編輯也叫xoopseditor嗎?



是,從XOOPS 2.3.* 起,一樣在/class/xoopseditor之下,已內建了編輯器。






[quote]
polomi 寫道:

當初我下載cbb3.08時,附註要一併下載Frameworks + xoopseditor ,所以才會一起裝。


因為XOOPS 2.3.* 之前的舊版本沒有Frameworks 和 xoopseditor ,所以才要另外下載 Frameworks + xoopseditor。

主頁:睡蓮‧池水間(支援Android4.0+及iOS5+)|論壇:風起漣漪|作品區:軒榭亭臺
discuss pic 2009-12-30 16:43:05
參照:

waterlily 寫道:
參照:

polomi 寫道:

XOOPS 2.42 版之下只要單用CBB3.08模組就可以了
連Frameworks + xoopseditor 也不用===>請問您,那內建的編輯也叫xoopseditor嗎?



是,從XOOPS 2.3.* 起,一樣在/class/xoopseditor之下,已內建了編輯器。






[quote]
polomi 寫道:

當初我下載cbb3.08時,附註要一併下載Frameworks + xoopseditor ,所以才會一起裝。


因為XOOPS 2.3.* 之前的舊版本沒有Frameworks 和 xoopseditor ,所以才要另外下載 Frameworks + xoopseditor。


感謝您,雖然電腦內現在已是XOOPS 2.4.2 , 但可能有許多重疊的東東,所以重來吧!加油
discuss pic 2009-12-30 16:53:47
xoops 2.42 也是ok
我試裝過 CBB3.08 在2.42 上也是很順利
沒有什麼問題的

您有屢敗屢戰精神呢
加油 ~ ^^
主頁:睡蓮‧池水間(支援Android4.0+及iOS5+)|論壇:風起漣漪|作品區:軒榭亭臺
discuss pic 2009-12-31 00:19:16
參照:

waterlily 寫道:
xoops 2.42 也是ok
我試裝過 CBB3.08 在2.42 上也是很順利
沒有什麼問題的

您有屢敗屢戰精神呢
加油 ~ ^^


xoops2.4.2加newbb3.08終於架設成功了。
我用的系統是:
作業系統:linux-centos5.3
php 5.x
mysql 5.x
phpmyAdMin 2.7.x
xoops 2.4.2 tchinese_utf8
newbb 3.08 tchinese_utf8
網站:使用no-ip的網址,並在個人目錄下建立個人的網站

目前架好系統、討論區、保護模組,其它的繼續加油中
前幾天失的原因應該是:
1、路徑錯亂
2、改太多檔案的名稱(因為要把它改為tchinese_utf8)
3、確定只要xoops2.4.2及newbb3.08就可以有編輯模組。

就這樣囉,謝謝幫忙的waterlily 大大。
這篇文我也登在我那剛出爐的xoops網站。
第一頁 上一頁 1 下一頁 最後頁
:::

即時留言簿


計數器

今天: 399399399
昨天: 1014101410141014
總計: 4021257402125740212574021257402125740212574021257